Commit 16 Contents:

1-Fossa Update
24 jobs for trusted-users/nikhil/NotifServiceRedesign in 19 minutes and 59 seconds (queued for 5 seconds)
Status Job ID Name Coverage
  .Pre
failed deprecated-aws-include #471155
osdu-small allowed to fail

00:00:06

failed deprecated-pipeline-include #471154
allowed to fail

00:00:07

 
  Review
passed trusted-merge-branch-verification #471156
osdu-small

00:01:59

 
  Build
passed compile-and-unit-test #471157
osdu-medium

00:04:19

 
  Containerize
passed aws-containerize #471161
osdu-medium

00:00:53

passed azure_containerize #471158
osdu-medium

00:01:00

passed osdu-gcp-containerize-gcloud #471159

00:02:24

passed osdu-gcp-containerize-gitlab #471160
osdu-medium

00:00:52

 
  Scan
passed bandit-sast #471164
osdu-medium

00:03:01

passed fossa-analyze #471162
osdu-medium

00:07:22

passed gemnasium-maven-dependency_scanning #471163
osdu-medium

00:03:18

passed license_scanning #471167
osdu-medium

00:03:08

passed semgrep-sast #471165
osdu-medium

00:02:22

passed spotbugs-sast #471166
osdu-large

00:13:30

 
  Deploy
passed aws-update-ecs #471170
osdu-medium

00:00:38

passed azure_deploy #471168
osdu-medium

00:01:48

passed ibm-deploy #471171
osdu-medium

00:01:31

passed osdu-gcp-deploy #471169

00:00:59

 
  Integration
passed aws-test-java #471174
osdu-medium

00:02:09

passed azure_test #471172
osdu-medium

00:07:31

passed ibm-test #471175
osdu-medium

00:02:13

passed osdu-gcp-test #471173
osdu-medium

00:03:33

 
  Attribution
passed fossa-check-notice #471176
osdu-small

00:00:57

passed fossa-report #471177
osdu-small

00:00:24

 
Name Stage Failure
failed
deprecated-pipeline-include .Pre
Reinitialized existing Git repository in /builds/osdu/platform/system/notification/.git/
Checking out 5a0a6e30 as trusted-users/nikhil/NotifServiceRedesign...

Skipping Git submodules setup
Executing "step_script" stage of the job script
$ echo "$DEPRECATED_MSG"
The FOSSA scanner now supports different build environments, which should be specified directly. Consider using fossa-maven.yml instead.
$ /bin/false
ERROR: Job failed: exit code 1
failed
deprecated-aws-include .Pre

Skipping Git submodules setup
Executing "step_script" stage of the job script
Using docker image sha256:d4ff818577bc193b309b355b02ebc9220427090057b54a59e73b79bdfe139b83 for alpine:latest with digest alpine@sha256:234cb88d3020898631af0ccbbcca9a66ae7306ecd30c9720690858c1b007d2a0 ...
$ echo "$DEPRECATED_MSG"
The AWS includes now support different build environments, which should be specified directly. Consider using: aws-global.yml, and either aws-maven.yml or aws-python.yml
$ /bin/false
Cleaning up file based variables
ERROR: Job failed: exit code 1