BlobStorage-lib/Bug: update requirement to use core azure lib with upgraded...

Cyril Monmouton requested to merge fix/upgrade-blobstorage-lib into master

BlobStorage-lib/Bug: update requirement to use core azure lib with upgraded version of blobstorage client as preconized by azure sdk team (https://github.com/Azure/azure-sdk-for-python/issues/19412)

Merge request reports