Commit 92089e37 authored by kiranveerapaneni's avatar kiranveerapaneni
Browse files

Updating readme doc for Istio config

parent 8e41ad48
Pipeline #8846 failed with stage
in 7 seconds
......@@ -47,9 +47,7 @@ az keyvault secret show --vault-name $KEY_VAULT_NAME --name $KEY_VAULT_SECRET_NA
| `cosmosdb_account` | ex `devintosdur2cosmosacct` | Cosmos account name | no | output of infrastructure deployment |
| `cosmosdb_key` | `********` | Key for CosmosDB | yes | output of infrastructure deployments |
| `cosmosdb_database` | ex `dev-osdu-r2-db` | Cosmos database for documents | no | output of infrastructure deployment |
| `azure.activedirectory.client-id` | `********` | AAD client application ID | yes | output of infrastructure deployment |
| `azure.activedirectory.AppIdUri` | `api://${azure.activedirectory.client-id}` | URI for AAD Application | no | -- |
| `azure.activedirectory.session-stateless` | `true` | Flag run in stateless mode (needed by AAD dependency) | no | -- |
| `ELASTIC_CACHE_EXPIRATION` | `1` | Credentials cache expiration | no | - |
| `MAX_CACHE_VALUE_SIZE` | `60` | Cache size | no | - |
| `KEYVAULT_URI` | ex `https://foo-keyvault.vault.azure.net/` | URI of KeyVault that holds application secrets | no | output of infrastructure deployment |
......@@ -58,8 +56,22 @@ az keyvault secret show --vault-name $KEY_VAULT_NAME --name $KEY_VAULT_SECRET_NA
| `AZURE_CLIENT_SECRET` | `********` | Secret for `$AZURE_CLIENT_ID` | yes | keyvault secret: `$KEYVAULT_URI/secrets/app-dev-sp-password` |
| `azure.application-insights.instrumentation-key` | `********` | API Key for App Insights | yes | output of infrastructure deployment |
| `appinsights_key` | `********` | API Key for App Insights | yes | output of infrastructure deployment |
In Order to run service with AAD authentication add below environment variables, which will enable Authentication in search service using AAD filter.
| name | value | description | sensitive? | source |
| --- | --- | --- | --- | --- |
| `azure_istioauth_enabled` | `false` | Flag to Disable AAD auth | no | -- |
| `azure_activedirectory_session_stateless` | `true` | Flag run in stateless mode (needed by AAD dependency) | no | -- |
| `azure_activedirectory_client_id` | `********` | AAD client application ID | yes | output of infrastructure deployment |
In Order to run service without authentication add below environment variables, which will disable authentication in search service.
name | value | description | sensitive? | source |
| --- | --- | --- | --- | --- |
| `azure_istioauth_enabled` | `true` | Flag to Disable AAD auth | no | -- |
**Required to run integration tests**
| name | value | description | sensitive? | source |
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment