Commit 14518a2e authored by David Diederich's avatar David Diederich
Browse files

Updating library dependencies to use release versions

parent bb035710
Pipeline #44628 failed with stages
in 1 minute and 5 seconds
......@@ -44,7 +44,7 @@
<log4j-core.version>2.13.2</log4j-core.version>
<google-oauth-client.version>1.31.0</google-oauth-client.version>
<commons-compress.version>1.20</commons-compress.version>
<osdu.oscorecommon.version>0.9.0-SNAPSHOT</osdu.oscorecommon.version>
<osdu.oscorecommon.version>0.9.0</osdu.oscorecommon.version>
<tomcat-embed-core.version>9.0.45</tomcat-embed-core.version>
</properties>
......
......@@ -38,8 +38,7 @@
<project.main.basedir>${project.parent.basedir}</project.main.basedir>
<aws.version>1.11.637</aws.version>
<deployment.environment>dev</deployment.environment>
<version.number>0.0.4-SNAPSHOT</version.number>
<osdu.oscorecommon.version>0.9.0-rc4</osdu.oscorecommon.version>
<osdu.oscorecommon.version>0.9.0</osdu.oscorecommon.version>
</properties>
<dependencies>
......
......@@ -36,8 +36,8 @@
<failOnMissingWebXml>false</failOnMissingWebXml>
<project.main.basedir>${project.parent.basedir}</project.main.basedir>
<springboot.version>2.1.7.RELEASE</springboot.version>
<osdu.corelibazure.version>0.9.0-rc1</osdu.corelibazure.version>
<osdu.oscorecommon.version>0.9.0-rc4</osdu.oscorecommon.version>
<osdu.corelibazure.version>0.9.0</osdu.corelibazure.version>
  • This upgrade is causing pipeline failure because com.microsoft.azure:azure-active-directory-spring-boot-starter is no longer supported in this version of core-lib-azure. @rvatolin could you please help here?

    Cc: @abpatil @kibattul @ankitsharma

  • Need to do upgrade to:

    <dependency>
        <groupId>com.azure.spring</groupId>
        <artifactId>azure-spring-boot-starter-active-directory</artifactId>
    </dependency>
Please register or sign in to reply
<osdu.oscorecommon.version>0.9.0</osdu.oscorecommon.version>
<osdu.search-core.version>0.9.0-SNAPSHOT</osdu.search-core.version>
<spatial4j.version>0.7</spatial4j.version>
<jts-io-common.version>1.15.0</jts-io-common.version>
......
......@@ -48,7 +48,7 @@
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>os-core-common</artifactId>
<version>0.9.0-rc4</version>
<version>0.9.0</version>
</dependency>
<dependency>
......
......@@ -49,12 +49,12 @@
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>core-lib-gcp</artifactId>
<version>0.9.0-SNAPSHOT</version>
<version>0.9.0</version>
</dependency>
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>os-core-common</artifactId>
<version>0.9.0-SNAPSHOT</version>
<version>0.9.0</version>
</dependency>
<dependency>
......
......@@ -23,9 +23,9 @@
<packaging>jar</packaging>
<properties>
<os-core-lib-ibm.version>0.9.0-SNAPSHOT</os-core-lib-ibm.version>
<os-core-lib-ibm.version>0.9.0</os-core-lib-ibm.version>
<start-class>org.opengroup.osdu.search.provider.ibm.app.SearchIBMApplication</start-class>
<osdu.oscorecommon.version>0.9.0-rc4</osdu.oscorecommon.version>
<osdu.oscorecommon.version>0.9.0</osdu.oscorecommon.version>
</properties>
......
......@@ -33,7 +33,7 @@
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>os-core-common</artifactId>
<version>0.9.0-rc4</version>
<version>0.9.0</version>
</dependency>
<dependency>
......
......@@ -25,7 +25,7 @@
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>os-core-common</artifactId>
<version>0.9.0-rc4</version>
<version>0.9.0</version>
</dependency>
<dependency>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment