Upgrade First Party Library Dependencies for Release 0.17

Merged David Diederich requested to merge dependency-upgrade into master

This automated MR upgrades the first party libraries (other OSDU libraries) to utilize the latest release. The intent is to keep the OSDU projects utilizing the latest available code to ensure widespread usage and stability. However, any library that is older than the previous release will be left as-is, since the upgrade is likely to be more complicated. Furthermore, the upgrade should only be merged in the CI pipeline reports success.

If this MR has failed, we can spend a little time investigating to see if a trivial upgrade could achieve compatiblity to the new library. But significant upgrade efforts should not occur on this MR, as part of the release tagging process. Instead, significant work should be scheduled for a subsequent milestone.

Dependency Information Before the Upgrade

Branch: master
SHA:    a1f2281e2a4f430002b972a7eb630a7bd85b206f
Maven:  0.17.0-SNAPSHOT
Python: 1.0.0
Maven Dependencies Root provider/crs-converter-gcp/crs-converter-gae/
core-lib-azure 0.15.2
core-lib-gcp 0.15.0
obm 0.15.0
oqm 0.15.0
os-core-common 0.17.0-rc2 0.17.0-rc2
os-core-lib-ibm 0.17.0-rc3
osm 0.15.0
(3rd Party) com.fasterxml.jackson.core.jackson-databind 2.13.2, 2.13.2.2 2.13.2.2
(3rd Party) org.springframework.spring-webflux 5.3.12
(3rd Party) org.springframework.spring-webmvc 5.3.22 5.3.22
No Python dependencies to show. (No first-party dependencies, and all third-party dependencies are hidden)
Critical: Found Vulnerable Jackson Databind dependency (<2.12.6.1 || >=2.13.0 <2.13.2.1)
└─ _Root_
└─ org.springdoc.springdoc-openapi-ui == 1.6.9
└─ org.springdoc.springdoc-openapi-webmvc-core == 1.6.9
└─ org.springdoc.springdoc-openapi-common == 1.6.9
└─ org.springframework.boot.spring-boot-autoconfigure == 2.7.2
└─ io.swagger.core.v3.swagger-core == 2.2.0
└─ com.fasterxml.jackson.core.jackson-databind == 2.13.2
Warning: Found Vulnerable Spring WebFlux dependency (<5.2.20 || >=5.3.0 <5.3.18)
└─ _Root_
└─ org.opengroup.osdu.crs-converter-service.crs-converter-aks == 0.17.0-SNAPSHOT
└─ com.azure.spring.azure-spring-boot-starter-active-directory == 3.4.0
└─ org.springframework.boot.spring-boot-starter-webflux == 2.4.12
└─ org.springframework.spring-webflux == 5.3.12

Dependency Information After the Upgrade

Branch: dependency-upgrade
SHA:    9579215ca9329ec8c87ae2a0df3593fd4da0f030
Maven:  0.17.0-SNAPSHOT
Python: 1.0.0
Maven Dependencies Root provider/crs-converter-gcp/crs-converter-gae/
core-lib-azure 0.15.2
core-lib-gcp 0.15.0
obm 0.15.0
oqm 0.15.0
os-core-common 0.17.0 0.17.0
os-core-lib-ibm 0.17.0
osm 0.15.0
(3rd Party) com.fasterxml.jackson.core.jackson-databind 2.13.2, 2.13.2.2 2.13.2.2
(3rd Party) org.springframework.spring-webflux 5.3.12
(3rd Party) org.springframework.spring-webmvc 5.3.22 5.3.22
No Python dependencies to show. (No first-party dependencies, and all third-party dependencies are hidden)
Critical: Found Vulnerable Jackson Databind dependency (<2.12.6.1 || >=2.13.0 <2.13.2.1)
└─ _Root_
└─ org.springdoc.springdoc-openapi-ui == 1.6.9
└─ org.springdoc.springdoc-openapi-webmvc-core == 1.6.9
└─ org.springdoc.springdoc-openapi-common == 1.6.9
└─ org.springframework.boot.spring-boot-autoconfigure == 2.7.2
└─ io.swagger.core.v3.swagger-core == 2.2.0
└─ com.fasterxml.jackson.core.jackson-databind == 2.13.2
Warning: Found Vulnerable Spring WebFlux dependency (<5.2.20 || >=5.3.0 <5.3.18)
└─ _Root_
└─ org.opengroup.osdu.crs-converter-service.crs-converter-aks == 0.17.0-SNAPSHOT
└─ com.azure.spring.azure-spring-boot-starter-active-directory == 3.4.0
└─ org.springframework.boot.spring-boot-starter-webflux == 2.4.12
└─ org.springframework.spring-webflux == 5.3.12

Merge request reports