Commit 6026d4f5 authored by Yauheni Lesnikau's avatar Yauheni Lesnikau
Browse files

fix whitesource issues

parent 98054e45
Pipeline #88170 failed with stages
in 52 minutes and 59 seconds
......@@ -17,8 +17,23 @@
<properties>
<commons-beanutils.version>1.9.4</commons-beanutils.version>
<osdu.oscorecommon.version>0.13.0-rc6</osdu.oscorecommon.version>
<spring-security-web.version>5.4.9</spring-security-web.version>
<gson.version>2.8.9</gson.version>
<netty.version>4.1.70.Final</netty.version>
</properties>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>io.netty</groupId>
<artifactId>netty-bom</artifactId>
<version>${netty.version}</version>
<type>pom</type>
<scope>import</scope>
</dependency>
</dependencies>
</dependencyManagement>
<dependencies>
<dependency>
......@@ -61,6 +76,17 @@
<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-security</artifactId>
<exclusions>
<exclusion>
<groupId>org.springframework.security</groupId>
<artifactId>spring-security-web</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.springframework.security</groupId>
<artifactId>spring-security-web</artifactId>
<version>${spring-security-web.version}</version>
</dependency>
<dependency>
<groupId>org.springframework.boot</groupId>
......@@ -111,7 +137,7 @@
<dependency>
<groupId>com.google.code.gson</groupId>
<artifactId>gson</artifactId>
<version>2.8.5</version>
<version>${gson.version}</version>
</dependency>
<dependency>
<groupId>com.google.http-client</groupId>
......
......@@ -54,10 +54,26 @@
<reactor-core.version>3.4.6</reactor-core.version>
<jackson-dataformat-xml.version>2.11.4</jackson-dataformat-xml.version>
<oauth2-oidc-sdk.version>6.5</oauth2-oidc-sdk.version>
<gson.version>2.8.9</gson.version>
<spring-core.version>5.3.12</spring-core.version>
<netty.version>4.1.70.Final</netty.version>
<spring-security-web.version>5.4.9</spring-security-web.version>
</properties>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>io.netty</groupId>
<artifactId>netty-bom</artifactId>
<version>${netty.version}</version>
<type>pom</type>
<scope>import</scope>
</dependency>
<dependency>
<groupId>org.springframework.security</groupId>
<artifactId>spring-security-web</artifactId>
<version>${spring-security-web.version}</version>
</dependency>
<!-- Override version defined in parent's POM -->
<dependency>
<groupId>io.projectreactor.netty</groupId>
......@@ -313,6 +329,11 @@
<artifactId>oauth2-oidc-sdk</artifactId>
<version>${oauth2-oidc-sdk.version}</version>
</dependency>
<dependency>
<groupId>com.google.code.gson</groupId>
<artifactId>gson</artifactId>
<version>${gson.version}</version>
</dependency>
</dependencies>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment