Commit 4b614d0e authored by Spencer Sutton's avatar Spencer Sutton Committed by David Diederich
Browse files

Patching log4j vulnerability

(cherry picked from commit 1ec7598c)
parent a08759c8
......@@ -32,6 +32,7 @@
<snakeyaml.version>1.26</snakeyaml.version>
<commons-codec.version>1.14</commons-codec.version>
<nimbusds.version>7.9</nimbusds.version>
<log4j2.version>2.16.0</log4j2.version>
</properties>
<licenses>
......@@ -53,6 +54,21 @@
<type>pom</type>
<scope>import</scope>
</dependency> -->
<dependency>
<groupId>org.apache.logging.log4j</groupId>
<artifactId>log4j-to-slf4j</artifactId>
<version>${log4j2.version}</version>
</dependency>
<dependency>
<groupId>org.apache.logging.log4j</groupId>
<artifactId>log4j-api</artifactId>
<version>${log4j2.version}</version>
</dependency>
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>os-core-common</artifactId>
<version>${os-core-common.version}</version>
</dependency>
<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-dependencies</artifactId>
......@@ -85,11 +101,6 @@
<artifactId>snakeyaml</artifactId>
<version>${snakeyaml.version}</version>
</dependency> -->
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>os-core-common</artifactId>
<version>${os-core-common.version}</version>
</dependency>
</dependencies>
</dependencyManagement>
......
......@@ -58,7 +58,7 @@
<dependency>
<groupId>org.opengroup.osdu.core.aws</groupId>
<artifactId>os-core-lib-aws</artifactId>
<version>0.12.0</version>
<version>0.13.0-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>org.opengroup.osdu</groupId>
......
......@@ -37,8 +37,8 @@
<java.version>1.8</java.version>
<maven.compiler.target>1.8</maven.compiler.target>
<maven.compiler.source>1.8</maven.compiler.source>
<osdu.corelibazure.version>0.12.0</osdu.corelibazure.version>
<osdu.oscorecommon-version>0.12.0</osdu.oscorecommon-version>
<osdu.corelibazure.version>0.13.0-rc5</osdu.corelibazure.version>
<osdu.oscorecommon-version>0.13.0-rc3</osdu.oscorecommon-version>
<nimbus-jose-jwt.version>7.9</nimbus-jose-jwt.version>
</properties>
......
......@@ -49,7 +49,7 @@
<dependency>
<groupId>org.opengroup.osdu</groupId>
<artifactId>core-lib-gcp</artifactId>
<version>0.9.0</version>
<version>0.13.0-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>org.springframework.cloud</groupId>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment