requirements_dev.txt 4.07 KB
Newer Older
1
2
3
4
5
6
7
8
#
# This file is autogenerated by pip-compile with python 3.7
# To update, run:
#
#    pip-compile requirements_dev.in
#
--extra-index-url https://community.opengroup.org/api/v4/projects/465/packages/pypi/simple/

9
anyio==3.2.1
10
11
12
    # via
    #   -c requirements.txt
    #   httpcore
13
attrs==21.2.0
14
15
16
17
    # via
    #   -c requirements.txt
    #   jsonschema
    #   pytest
18
certifi==2021.5.30
19
20
21
22
    # via
    #   -c requirements.txt
    #   httpx
    #   requests
23
cffi==1.14.6
24
25
26
    # via
    #   -c requirements.txt
    #   cryptography
27
charset-normalizer==2.0.3
28
29
30
    # via
    #   -c requirements.txt
    #   requests
31
click==8.0.1
32
33
34
    # via
    #   -c requirements.txt
    #   pip-tools
35
coverage==5.5
36
    # via pytest-cov
37
cryptography==3.4.7
38
39
40
41
    # via
    #   -c requirements.txt
    #   -r requirements_dev.in
    #   pyjwt
42
h11==0.12.0
43
44
45
    # via
    #   -c requirements.txt
    #   httpcore
46
httpcore==0.13.6
47
48
49
    # via
    #   -c requirements.txt
    #   httpx
50
httpx==0.18.2
51
52
53
54
    # via
    #   -c requirements.txt
    #   -r requirements_dev.in
    #   pytest-httpx
55
idna==3.2
56
57
58
59
60
    # via
    #   -c requirements.txt
    #   anyio
    #   requests
    #   rfc3986
61
importlib-metadata==4.6.4
62
63
64
65
66
67
68
    # via
    #   -c requirements.txt
    #   click
    #   jsonschema
    #   pep517
    #   pluggy
    #   pytest
69
iniconfig==1.1.1
70
    # via pytest
71
isodate==0.6.0
72
73
74
    # via
    #   -c requirements.txt
    #   openapi-schema-validator
75
jsonschema==3.2.0
76
77
78
79
    # via
    #   -r requirements_dev.in
    #   openapi-schema-validator
    #   openapi-spec-validator
80
mock==4.0.3
81
    # via -r requirements_dev.in
Luc Yriarte's avatar
Luc Yriarte committed
82
83
mockito==1.2.2
    # via -r requirements_dev.in
84
munch==2.5.0
85
    # via -r requirements_dev.in
86
numpy==1.21.1
87
88
89
90
91
    # via
    #   -c requirements.txt
    #   -r requirements_dev.in
    #   pandas
    #   pyarrow
92
openapi-schema-validator==0.1.5
93
    # via openapi-spec-validator
94
openapi-spec-validator==0.3.1
95
    # via -r requirements_dev.in
96
packaging==21.0
97
98
99
    # via
    #   -c requirements.txt
    #   pytest
100
pandas==1.2.4
101
102
103
104
105
    # via
    #   -c requirements.txt
    #   -r requirements_dev.in
pep517==0.11.0
    # via pip-tools
106
pip-tools==6.2.0
107
    # via -r requirements_dev.in
108
pluggy==0.13.1
109
    # via pytest
110
py==1.10.0
111
    # via pytest
112
pyarrow==4.0.1
113
114
115
    # via
    #   -c requirements.txt
    #   -r requirements_dev.in
116
pycparser==2.20
117
118
119
120
121
122
123
    # via
    #   -c requirements.txt
    #   cffi
pyjwt[crypto]==2.1.0
    # via
    #   -c requirements.txt
    #   -r requirements_dev.in
124
pyparsing==2.4.7
125
126
127
    # via
    #   -c requirements.txt
    #   packaging
128
pyrsistent==0.18.0
129
    # via jsonschema
130
pytest==6.2.4
131
132
133
134
135
136
137
    # via
    #   -r requirements_dev.in
    #   pytest-asyncio
    #   pytest-cov
    #   pytest-dependency
    #   pytest-httpx
    #   pytest-mock
138
pytest-asyncio==0.15.1
139
    # via -r requirements_dev.in
140
pytest-cov==2.12.1
141
    # via -r requirements_dev.in
142
pytest-dependency==0.5.1
143
    # via -r requirements_dev.in
144
pytest-httpx==0.12.0
145
    # via -r requirements_dev.in
146
pytest-mock==3.6.1
147
    # via -r requirements_dev.in
148
python-dateutil==2.8.2
149
150
151
    # via
    #   -c requirements.txt
    #   pandas
152
pytz==2021.1
153
154
155
156
157
158
159
    # via
    #   -c requirements.txt
    #   pandas
pyyaml==5.4.1
    # via
    #   -c requirements.txt
    #   openapi-spec-validator
160
requests==2.26.0
161
162
163
164
165
166
167
    # via
    #   -c requirements.txt
    #   -r requirements_dev.in
rfc3986[idna2008]==1.5.0
    # via
    #   -c requirements.txt
    #   httpx
168
six==1.16.0
169
170
171
172
173
174
175
176
    # via
    #   -c requirements.txt
    #   isodate
    #   jsonschema
    #   munch
    #   openapi-schema-validator
    #   openapi-spec-validator
    #   python-dateutil
177
sniffio==1.2.0
178
179
180
181
182
    # via
    #   -c requirements.txt
    #   anyio
    #   httpcore
    #   httpx
183
toml==0.10.2
184
185
186
187
188
    # via
    #   pytest
    #   pytest-cov
tomli==1.2.0
    # via pep517
189
typing-extensions==3.10.0.0
190
191
192
193
    # via
    #   -c requirements.txt
    #   anyio
    #   importlib-metadata
194
urllib3==1.26.6
195
196
197
198
199
200
201
202
203
204
205
206
207
208
    # via
    #   -c requirements.txt
    #   requests
wheel==0.36.2
    # via pip-tools
zipp==3.5.0
    # via
    #   -c requirements.txt
    #   importlib-metadata
    #   pep517

# The following packages are considered to be unsafe in a requirements file:
# pip
# setuptools