setup.py 1.04 KB
Newer Older
1
2
3
import os
import re
from setuptools import setup, find_packages
Luc Yriarte's avatar
Luc Yriarte committed
4
5
from osdu_gcp import __version__ as osdu_gcp_version

6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

requirements_file = os.path.abspath(
    os.path.join(os.path.dirname(__file__), 'requirements.txt')
)

test_requirements_file = os.path.abspath(
    os.path.join(os.path.dirname(__file__), 'requirements_dev.txt')
)

with open(requirements_file) as f:
    requirements = f.read().splitlines()

with open(test_requirements_file) as f:
    test_requirements = f.read().splitlines()

setup(
    name='osdu-core-lib-python-gcp',

Luc Yriarte's avatar
Luc Yriarte committed
24
    version=osdu_gcp_version,
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43

    packages=find_packages(),

    author="OSDU Wellbore data domain services team",

    author_email="WellboreDDMS@slb.com",

    description="OSDU python for wellbore DMS - google cloud implementations",

    long_description=open('README.md').read(),

    include_package_data=True,

    install_requires=requirements,

    tests_require=test_requirements,

    license="Apache License, Version 2.0",

44
45
    # We need py 3.8 for some of the tools used here
    python_requires='>=3.8',
46
)