Commit 91d9f7d6 authored by Niall McDaid's avatar Niall McDaid
Browse files

Fix install issues

parent 9717aef1
Pipeline #76473 passed with stage
in 35 seconds
......@@ -47,20 +47,27 @@ setup(
include_package_data=True,
entry_points={"console_scripts": ["lascli=lasloader.__main__:main"]},
install_requires=[
"anyio==3.3.4; python_full_version >= '3.6.2'",
"argcomplete==1.12.3",
"colorama==0.4.4; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3, 3.4'",
"certifi==2021.10.8",
"charset-normalizer==2.0.7; python_version >= '3.5'",
"h11==0.12.0; python_version >= '3.6'",
"httpcore==0.13.7; python_version >= '3.6'",
"httpx==0.20.0",
"idna==3.3",
"jmespath==0.10.0; python_version >= '2.6' and python_version not in '3.0, 3.1, 3.2, 3.3'",
"knack==0.8.2",
"knack==0.9.0",
"lasio==0.29",
"numpy==1.21.3; python_version < '3.10' and platform_machine != 'aarch64' and platform_machine != 'arm64'",
"numpy==1.21.4; python_version < '3.10' and platform_machine != 'aarch64' and platform_machine != 'arm64'",
"pandas==1.3.4",
"pyarrow==6.0.0",
"pygments==2.10.0; python_version >= '3.5'",
"python-dateutil==2.8.2; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'",
"pytz==2021.3",
"pyyaml==6.0; python_version >= '3.6'",
"rfc3986[idna2008]==1.5.0",
"six==1.16.0; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'",
"sniffio==1.2.0; python_version >= '3.5'",
"tabulate==0.8.9",
"toml==0.10.2",
],
)
......@@ -8,6 +8,7 @@ lasio = "*"
knack = "*"
pandas = "*"
pyarrow = "*"
httpx = "*"
[dev-packages]
flake8 = "*"
......
This diff is collapsed.
......@@ -53,7 +53,6 @@ class LasCommandLoader(CLICommandsLoader):
group.command('wellbore', 'wellbore')
group.command('welllog', 'welllog')
group.command('curves', 'welllog_data')
group.command('wellbore_search', 'wellbore_search')
with CommandGroup(self, 'update', 'lasloader.commands.update#{}') as group:
group.command('welllog', 'welllog')
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment